WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3

Enviada por Hélio Oliveira 
Hélio Oliveira
WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
15 de October de 2010 às 12:44PM
Boa tarde Colegas!

Nunca desenvolvi nada para Web e agora vou começar a me aventurar. Comprei um livro para me auxiliar nesta empreitada inicial, porém durante o processo de instalação do Apache/PHP estou enfrentando problemas - que relatarei abaixo.

1 - Instalo normalmente o Apache 2.2.16 - serviço é iniciado;

2 - Instalo o PHP (já tentei as versões 5.2.14 e 5.3.3) e em ambas durante o processo de instalação ocorre o seguinte erro: Error trying access httpd.conf file. You will need to manually configure the web server.
Pelo que li no livro e também encontrei algumas informações na net, editei o arquivo httpd.conf e acrescentei as seguintes linhas:

#BEGIN PHP INSTALLER EDITS
PHPIniDir "C:\Program Files\PHP\"
LoadModule php5_module "C:\Program Files\PHP\php5apche2_2.dll"
#END PHP INSTALLER EDITS

3 - Após fazer a alteração, paro o serviço do Apache e tento iniciar o mesmo, porém ocorre o seguinte erro: The requested operation has failed!

Algum colega que tenha passado por problema parecido ou igual poderia me indicar o caminho das pedras..

[]'s,
Hélio
Marcos Regis
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
15 de October de 2010 às 03:16PM
O primeiro erro tem duas possiveis razoes

O Apache estava sendo executado enquanto vc tentou instalar o PHP (sempre pare o serviço para instalar qq coisa nele) e este é o mais provável.
O instalador do PHP não teve permissão de escrita no arquivo httpd.conf - Neste caso execute o instalado como Administrador (botão direito=>Executar como Administrador).

O outro erro pode ser que tenha baixado o instalador errado.

Tem que ser esse http://windows.php.net/downloads/releases/php-5.3.3-Win32-VC9-x86.msi
Hélio Oliveira
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
18 de October de 2010 às 11:11AM
Boa tarde Marcos!

Muito obrigado pela ajuda.

Como todo iniciante andei realmente fazendo algumas barberagens...
Quando estava instalando o PHP durante o processo há uma etapa onde devemos informar o caminho de onde estar instalado o Apache para que seja feita as alterações necessárias no arquivo http.conf e eu estava simplesmente clicando em next sem prestar atenção.... daí foi só informar o caminho correto e pronto.

+ um detalhe - tratando-se de windows 7, logo após terminar a instalação do apache eu cliquei com o botão direito sobre a pasta do mesmo e nas propriedades editei as permissões dos usuários concedendo controle total - desta forma o php ou qualquer outro aplicativo que necessite fazer interação com o apache não terá problema de permissão.

[]'s,
Hélio Oliveira
Ariston Gomes Pereira
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
23 de October de 2010 às 10:41AM
Amigos
entrando de cunha nestas soluções de vocês, estou receoso de ter um problema similar, pois vejam e peço ajuda:

Gostaria de configurar o PHP no IIS 7. Estou usando o win7 e IIS7 e no site PHP.net baixei um pacote de
quatro aplicativo para fazer isso, como se vê abaixo:

php-5.3.3-src---------------------------------------------------code source 19.1MB
php-5.3.3-nts-Win32-VC9-x86.zip------------------------- 14.4MB
php-5.3.3-Win32-VC9-x86.msi----------------------------- 26.8MB
php-debug-pack-5.3.3-nts-Win32-VC9-x86.zip--------- 7,8MB

Peço ajuda e pergunto: Qual o procedimento e sequência de instalação destes itens para ter o PHP rodando
na plataforma windows?
savio
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
06 de July de 2011 às 06:21AM
Helio,
Obrigado pelo registro da solução do seu problema. Você não foi o único a fazer uma barbeiragem neste passo.

Abraço.
Zero Fernandes
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
16 de March de 2012 às 01:34PM
Veja tutorial de instalação para o Apache a PHP e o MySQL de forma personalizada em:

http://ed48.com/rsr/AMP/

zerof
diego raphael de almeida simoes
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
22 de March de 2012 às 10:16AM
Tive o mesmo problema e foi so baixar o arquivo "ntwdblib.dll" no
link http://www.arquivos-dll.com/N/ntwdblib.dll.html
e descompactar na pasta system32
Zero Fernandes
Re: WIndows 7 + Apache 2.2.16 + PHP 5.2.14/5.3.3
29 de March de 2012 às 05:07PM
Aproveitando...

A partir da versão 5.4.0, a PHP passa a oferecer uma alternativa para ambiente de desenvolvimento.
O modo CLI oferece a opção de execução sem a necessidade de instalação de um servidor, pois, passa a contar com um servidor interno.
Mais detalhes em:

http://php.net/manual/en/features.commandline.webserver.php
Você precisa estar logado no PHPBrasil.com para poder enviar mensagens para os nossos fóruns.

Faça o login aqui.