Apache não inicia no Windows 7

Enviada por Cesar 
Cesar
Apache não inicia no Windows 7
23 de September de 2010 às 08:00PM
Pessoal esta é minha primeria postagem aqui no forum, que por sinal vem me ajudando muito, mais estou com um problema que gostaria da ajudade vocês.
E o seguinte Instalei o apache 2.053 e o php 4.3.9 fiz todas as configurações mas quando tento iniciar o apache aparece a seguinte mensagem: "O Windows não pôde iniciar o Apache em Computador Local. Para obter mais informações, examine o log de eventos do sistema. Se este for um serviço não-Microsoft, contate o fornecedor do serviço e informe o o código de erro específico do serviço 1."

O log de erro é este:

[Mon Sep 20 17:34:33 2010] [notice] Apache/2.0.53 (Win32) configured -- resuming normal operations
[Mon Sep 20 17:34:33 2010] [notice] Server built: Feb 10 2005 06:11:34
[Mon Sep 20 17:34:33 2010] [notice] Parent: Created child process 2892
[Mon Sep 20 17:34:33 2010] [notice] Child 2892: Child process is running
[Mon Sep 20 17:34:33 2010] [notice] Child 2892: Acquired the start mutex.
[Mon Sep 20 17:34:33 2010] [notice] Child 2892: Starting 250 worker threads.
[Mon Sep 20 18:18:04 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:18:04 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/favicon.ico
[Mon Sep 20 18:18:04 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/favicon.ico
[Mon Sep 20 18:18:07 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/favicon.ico
[Mon Sep 20 18:18:33 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:19:07 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:19:07 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:19:12 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:19:27 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:32:18 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/teste.php
[Mon Sep 20 18:32:21 2010] [error] [client 127.0.0.1] File does not exist: C:/Apache2/htdocs/favicon.ico

Já desativei o IIS mais o erro ainda persiste, o que pode estar ocorrrendo?

Desde ja agradeço e conto com a ajuda de vocês!
Fabian Rodrigues Caetano
Re: Apache não inicia no Windows 7
17 de January de 2011 às 01:25PM
Estou tendo o mesmo problema.
Marcos Regis
Re: Apache não inicia no Windows 7
17 de January de 2011 às 01:50PM
vai no prompt de linha de comando e tenta iniciar o apache na mão.

c:\Apache2\bin\httpd -k start

e ve o erro que mostra na tela
Diego
Re: Apache não inicia no Windows 7
21 de April de 2011 às 09:45AM
tambem tive o mesmo problema...
resolvi removendo todos os componentes por ex.
apache, php, mysql

e instalando o xampp lite
ai consegui fazer funcionar...
mas é problema de sistema isso, pq depois de 2 dias,formatei o micro, voltei a instalar o apache,php e mysql e voltou a funcionar normalmente ;)
DiBem
Re: Apache não inicia no Windows 7
19 de August de 2011 às 03:17PM
Instalei o Apache na Porta 80, mas ao testá-lo notei que el não starta.
mostra uma mensagem de erro:

The requested operation failed!

Tentei startar manualmente pelo prompt (cmd) usando o seguinte comando e na sequência apareceu a mensagem de erro:

C:\Webserver\Apache 2.2\bin>httpd -k start

httpd: Could not reliably determine the server's fully qualified domain name, us ing 10.0.0.104 for ServerName
(OS 10013)Foi feita uma tentativa de acesso a um soquete de uma maneira que é proibida pelas permissões de acesso. : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs

Não sei o que fazer.. Já tentei instalar o Xampp, EasyPHP e o WampServer e todos não inicializam o Apache...
E com isso fica impossível utilizar o comando http://localhost no browser.

O que devo fazer? Alguma sugestão do que está acontecendo e como corrigir?
Lucas Tiago de Moraes
Re: Apache não inicia no Windows 7
19 de September de 2011 às 06:38PM
Amigo instale então o cygwin, que é linux dentro do windows.
O cygwin salvou windows no desenvolvimento :)

Falou.
Zero Fernandes
Re: Apache não inicia no Windows 7
16 de March de 2012 às 01:33PM
Pacotes de instalação do tipo tudo-em-um não são uma boa! Geralmente, são difícies de atualizar e configurar, (muita mão de obra).

Vejam no link abaixo, uma forma simples de instalar o sistema A+M+P, com possibilidades de instalação em qualquer letra de disco rígido fixo ou removivel e até mesmo em pendrives:

http://ed48.com/rsr/AMP/


zerof
Zero Fernandes
Re: Apache não inicia no Windows 7
29 de March de 2012 às 05:08PM
Aproveitando:

A partir da versão 5.4.0, a PHP passa a oferecer uma alternativa para ambiente de desenvolvimento.
O modo CLI oferece a opção de execução sem a necessidade de instalação de um servidor, pois, passa a contar com um servidor interno.
Mais detalhes em:

http://php.net/manual/en/features.commandline.webserver.php
Você precisa estar logado no PHPBrasil.com para poder enviar mensagens para os nossos fóruns.

Faça o login aqui.