0

SysLogue - Sistema Autenticacao Usuario

criado por Julian Dagolofi em 19/08/2004 5:13pm
Autenticação de usuários com controle de usuarios, privilégios, autenticação com verificação em cada pagina, LOG acesso, Verificação de SQL Injection, criptografia de senha antes do trafego até o Banco de Dados etc
Data Autor Changelog Download
19/08/2004 5:13pm Julian Dagolofi - Versão 1.1
27/08/2004 2:30pm Julian Dagolofi Versão 1.2 Versão 1.2
28/10/2004 2:23pm Julian Dagolofi Versão 2005 Versão 2005

Comentários:

Mostrando 1 - 5 de 5 comentários
Caro Sérgio Ricardo,

Primeiramente, peço-lhe desculpas pela demora em responder.

Eu uso Apache 1.3 com MySQL 4.14 gamma e PHP4.3.9 no Windows XP Pro

Imagino que possa ser, além da versão do Apache, a versão do MySQL que em algumas vezes vem com a função de Crypt() colocando "*" no inicio do campo de senha.

Veja se consegue inserir um usuário usando a Funcão/Metodo que está ao final da ClasseSenha.php e que insere um novo usuario. Você escolhe o usuario e a senha conforme o exemplo que reproduzo a seguir:


/*
$Novo = new senha;
$Novo->usuario = 'Julian';
$Novo->senha = $Novo->Criptografa('dagolofi');
$Novo->NomeCompleto = 'Julian Dagolofi';
$Novo->DtInclusao = date("Y/m/d H:i:s");

// Para Incluir Senha
$Novo->inclui();

$Novo->Adm = 'S';
$Novo->Ger = 'S';
$Novo->Usu = 'S';
$Novo->CodAcesso = '9';

//Atualizar Privilegio
$x=$Novo->AtualizaPrivilegio();

$Novo->privilegio = 'A';
// Para Verificar Senha
if ($Novo->confere())
{
echo "Verdadeiro";
}
else
{
echo "Falso";
}
*/

Espero que lhe seja de alguma ajuda.

Julian Dagolofi
21/02/2005 1:25pm (~11 anos atrás)

Olá Julian,

Aqui também não rodou, qual versão do Apache
MySql e PHP, você está utlizando?

Tem alguma configuração específica que deva ser setada?

Estou usando Apache2, MySql 4.1 e PHP 5.0.2.

Já tentei de tudo, ele cria o banco as tabelas e os usuários julian e lula, porém~, não autêntica de jeito nenhum, e também não dá nenhum erro, por exemplo:

se eu digito usuário: teste senha: teste

não está retornando nenhum erro, dizendo que o usuário/senha não existem.

Imagino que deva ser configuração, tenho um outro programa que faz autenticação e está funcionando corretamente.

Obrigado,

Sérgio Ricardo

31/01/2005 7:21am (~12 anos atrás)

Caro Lando,

Os usuarios do Banco não precisam ser criptografados na criação.

O Usuário Administrador do SysLogue que está na base LOGIN é 'julian' com a senha 'juliandagolofi' consoante está no arquivo leiame.txt.

Peço aos demais que pegaram o SysLogue que porventura tenham a mesma dificuldade relatem, pois nos testes que fiz não houve problema.

Julian Dagolofi
23/08/2004 1:52pm (~12 anos atrás)

EquipeXQ disse:

Não teria como disponibilizar já com os usuários criados?..o leiame não explica como inserir criptografado..se disponibilizar o banco pronto fica mais fácil...obrigado.
22/08/2004 1:11pm (~12 anos atrás)

Caros colegas,

Caso queiram contribuir no avanço do desenvolvimento, por favor queiram postar sugestões e/ou críticas.

No aguardo de melhoria no código e relatos de BUGs.

Um abraço,

Julian Dagolofi
20/08/2004 2:00pm (~12 anos atrás)

Novo Comentário:

(Você pode usar tags como <b>, <i> ou <code>. URLs serão convertidas para links automaticamente.)