Array de meses não quer funcionar!!!

Enviada por Julião Kaiser 
Julião Kaiser
Array de meses não quer funcionar!!!
05 de February de 2007 às 08:13AM
Socorro! Alguém me ajude a abrir os olhos...
Estou usando dentro de uma página, a rotina que mostra o nome do mes por extenso.
A rotina é esta descrita abaixo, mas retorna vazia...

<?
$data_hoje=date('Y-m-d');
$data_h=explode("-",$data_hoje);
$mes_atu =$data_h[1];
$tbl_meses=array("0","Janeiro","Fevereiro","Março","Abril","Maio","Junho","Julho","Agosto","Setembro","Outubro","Novembro","Dezembro");

// aqui em baixo eu tento mostrar o mês por extenso.
echo "O mes atual é $tbl_meses[$mes_atu]<br>";
?>

Onde será que eu estou cochilando???
Marcos Regis
Re: Array de meses não quer funcionar!!!
05 de February de 2007 às 09:23AM
jah tento dessa maneira

setlocale(LC_ALL,"ptb,pt_BR");
echo date("m");
Marcos Regis
Re: Array de meses não quer funcionar!!!
05 de February de 2007 às 11:35AM
Foi malz

o correto é
setlocale(LC_ALL,"ptb,pt_BR");
echo date("F");
Marcos Regis
Re: Array de meses não quer funcionar!!!
05 de February de 2007 às 01:57PM
bom...

Entaum tenta isso aqui

Aqui funciona normalmente

if ( preg_match("@Windows@i",$_SERVER['SERVER_SOFTWARE']) ) setlocale(LC_ALL,"ptb");
else setlocale(LC_ALL,"pt_BR");

echo "O mes atual e => ".strftime('%B');

Maiores detalhes em
http://www.php5.com.br/index.php?php=_artigos/mostra&id_cat=59
Você precisa estar logado no PHPBrasil.com para poder enviar mensagens para os nossos fóruns.

Faça o login aqui.