Problemas para instalar o php no apache

Enviada por Magno M. Paulo 
Magno M. Paulo
Problemas para instalar o php no apache
24 de February de 2003 às 06:44PM
Olá, eu baixei o php 4.3 e o apache 1.3.27, ambos para windows, mas não estou conseguindo utilizar o php.
O que eu fiz foi o seguinte:
Instalei o apache em uma pasta, o php em outra, copiei o php.ini-dist para o diretorio do windows, renomeando-o para php.ini e modifiquei o valor de extension_dir para c:/php/(pasta onde eu coloquei o php). Em seguida copiei o arquivo php4ts.dll para a pasta c:\windows\system\
Após isso, adicionei as seguintes linhas ao httpd.conf do apache:
LoadModule php4_module C:\php\sapi\php4apache.dll
AddType application/x-httpd-php .php

Porém, quando vou rodar o apache, recebo a seguinte mensagem:
Syntax erro on line 1023 of c:/arquivos de programas/apache group/apache/conf/httpd.conf:
Cannot load c:/php/sapi/php4apache.dllinto server: (1157) Não é possível encontrar um dos arquivos de biblioteca necessário para executar este aplicativo


Por favor, será que alguém pode ajudar a resolver isto?
Otacílio Ribeiro
Re: Problemas para instalar o php no apache
26 de March de 2003 às 03:37PM
Tente salvar o arquivo php.ini original que vem com o PHP para fazer o teste.
obara_hmw
Re: Problemas para instalar o php no apache
21 de July de 2003 às 02:24PM
experimente trocar o nome do arquivo .dll que aparece nessa linha:

LoadModule php4_module C:/php/sapi/php4apache.dll

para:

LoadModule php4_module C:/php/sapi/php4apache2.dll

Salve o arquivo e funcione o apache..

isso ocorre por que o php versão 4 ou superior acompanha o arquivo feito para a versões anteriores a 4.x.x (php4apache.dll) e também o arquivo para a versão = ou superior a 4.x.x (php4apache2.dll).
Kleber
Re: Problemas para instalar o php no apache
02 de August de 2003 às 09:54AM
Srs,

Estou com o mesmo problema, minha instalação do php nem ao menos tem este arquivo php4apache2.dll

Será que alguém gentilmente poderia me enviar este arquivo por e-mail ?
kleber.sotte@itelefonica.com.br
Ficariam muito agradecido.

Grato
Kleber.
Alisson
Re: Problemas para instalar o php no apache
03 de August de 2003 às 10:49AM
Eu gostaria de saber entre quais linhas devo adicionar o seguinte comando:

AddType application/x-httpd-php .php
LoadModule php4_module c:/php/sapi/php4apache.dll

Se alguém puder me ajudar, eu agradeço. Abraços.
antonio
Problemas no apache e php
23 de August de 2003 às 10:38PM
Estou com o seguinte erro no apache

Cannot load c:/php/sapi/php4apache.dll into server: (1157) Não é possível encontrar um dos arquivos de biblioteca necessário para executar este aplicativo

O amabiente é apache 13 e php4

Alguem pode me ajudar ?
Edilson
Re: Problemas no apache e php
25 de August de 2003 às 07:14PM
Kleber, este arquivo está oculto no diretorio sapi do php.
Você precisa estar logado no PHPBrasil.com para poder enviar mensagens para os nossos fóruns.

Faça o login aqui.