0

Problema no crypt

criado por Italo Marcelo de O. Costa em 22/08/2002 10:58am
Por que toda tentativa de executar o crypt, o resultado está começando com $1? Por exemplo, olha a codificacao e depois o resultado na tela

PHP VERSAO 4.1.2
CODIGO
$nome="italo";
echo "$nome<br>";
$n=crypt($nome);
echo "$n<br>";
$i=1;
$nome="italo".$i;
echo "$nome<br>";
$n=crypt($nome);
echo "$n<br>";
RESULTADO NO BROWSER
italo
$1$w7leU6QC$nrBvgz4GW2xiLLUky5XTV.
italo1
$1$E10YfGTG$QKgMkQyJLQlvOjsiNEVQj/

AGORA NA VERSAO 4.0.6
CODIGO IDENTICO
RESULTADO NO BROWSER
italo
OAN2zXgmc.ECA
italo1
UZ9qzQofE2ZRY

Lista de Respostas:

0
22/08/2002 3:58pm
(~14 anos atrás)
Mauro Luis Ribeiro respondeu:
Buenas !

Tchê, não sei ao certo qual o problema, mas tenho uma solucao, em vez de vc usar o crypt ..usa o md5...

Valeu,


Gordo

0
23/08/2002 7:48am
(~14 anos atrás)
Gostaria de saber o problema no crypt e não em utilizar outra forma de hash, alguém sabe o por que??

0
23/08/2002 11:24am
(~14 anos atrás)
Mauro Luis Ribeiro respondeu:
Buenas !

O que vale eh a intencao de ajudar, mas.....

Seguinte teste o teu codigo e fumegou legal...PHP 4.1.2 essa eh a versao que estou usando...acredito que possa ser config. do php.ini....espero assim agregado algo agora...

Valeu,

Gordo

0
24/08/2002 8:55am
(~14 anos atrás)
Valeu gordo pela resposta..... mas o q deve ter errado no config, pois executei este script no php da tripod e no php de um webserver da facul e deu o mesmo resultado..... todos começaram com $1...

Valeu e obrigado por enquanto.

0
26/08/2002 7:20am
(~14 anos atrás)
Em sistemas onde a função crypt() suporta variados tipos de codificação, as seguintes funções são definidas para 0 ou 1 a depender se um dado tipo está disponível:


CRYPT_STD_DES - Codificação Standard DES-based com um salt de 2 caracteres

CRYPT_EXT_DES - Codificação Extended DES-based com um salt de 9 caracateres

CRYPT_MD5 - Codificação MD5 com um salt de 12 caracteres começando com $1$

CRYPT_BLOWFISH - Codificação Blowfish com um salt de 16 caracteres começando com $2$

falou ?

:-)

0
23/02/2003 6:58pm
(~13 anos atrás)
como pego um senha que eu encriptei e desencripto ela??
jah tentei usar um script que achei aqui, mas nao deu certo...

0
26/03/2004 3:09pm
(~12 anos atrás)
Marcos Echevarria respondeu:
Também queria saber isso, eu uso o crypt normal, codifico a senha mas não consigo pegar ela depois, não consigo descodifica!

como eu faço?

Nova Resposta:

(Você pode usar tags como <b>, <i> ou <code>. URLs serão convertidas para links automaticamente.)