+2

Lançado PHP 5

criado por Marcelo Pereira Fonseca da Silva em 15/07/2004 10:37am
A nova versão do PHP foi oficialmente lançada dia 13 de julho de 2004.

Já existe uma série de documentos em inglês e alguns em português
falando sobre os novos recursos do PHP 5.

Mesmo os documentos não traduzidos para o nosso idioma não apresentam
uma dificuldade muito grande, é interessante ler ao menos o código fonte que está disponível nesses documentos.

O lançamento oficial da nova versão está em:

http://www.php.net

o Pablo Dall'Oglio criou um excelente material falando sobre os novos
features de OO que foram implementados nesta nova versão, e está disponível em:

http://www.rau-tu.unicamp.br/nou-rau/softwarelivre/document/list.php?tid=20

Alguns sites interessantes sobre recursos avançados:

http://www.horde.org/papers/kongress2002-design_patterns/
http://www.phppatterns.com
http://www.developer.com/lang/php/article.php/3302171
http://www.zend.com/zend/trick/tricks-app-patt-php.php

Boa parte dos documentos sobre os novos features podem ser encontrados
no site da Zend, sendo mais específico em:

http://www.zend.com/php5/whats-new.php

Boa leitura :)

Comentários:

Mostrando 1 - 10 de 11 comentários
Dam disse:
Bom artigo.
20/11/2008 4:26am (~8 anos atrás)

Galera,

Instalei o phptriad que contem a versão 4.1.1 do php. Para rodar um script preciso da versão mais atual, ou seja, php 5.
Pergunto: Posso instalar separadamente ? Qual configuração necessária ?
Grato pela atenção.
21/11/2004 9:20pm (~12 anos atrás)

na minha opinião, misturar html com php, independente de ser dentro de classe.. é fazer sujeira! :)
22/07/2004 3:43pm (~12 anos atrás)

Estou começando utilizar usar OOP e gostaria de saber é normal colocar html dentro de uma classe ou eu estaria fazendo sujeita???
21/07/2004 10:17am (~12 anos atrás)

eu to usando o wamp aqui dai só atualizei o php e ta funcionando normal http://www.wampserver.com
16/07/2004 3:36pm (~12 anos atrás)

Também acho que é uma boa idéia instalar o PHP manualmente..

tem algumas coisas mudando
algumas bibliotecas sendo atualizadas

vou ver se posto aqui algum link interessante
depois

sobre o mail server uma vez eu usei no windows..

há muuuuito tempo :)

o ArgoSoft MailServer

funcionou direitinho o programa..
achei ele no superdownloads
16/07/2004 6:01am (~12 anos atrás)

O artigo de Pablo é realmente excelente. Já imprimi e estou estudando.PHP deu um grande avanço na orientação a objeto. Parabéns a toda a comunidade.

15/07/2004 1:11pm (~12 anos atrás)

Nada muito complicado.
Vc só vai precisar instalar o php manualmente.Consulte o arquivo install.txt
É aconselhável continuar com o apache 1.3, pois a versão 2 é experimental, e quanto ao servidor SMTP, já utilizei o CMAIL SERVER,
http://www.youngzsoft.net/cmailserver/cmailsetup.exe
É bom, mas limitado para 5 usuários.
15/07/2004 12:01pm (~12 anos atrás)

miq disse:
Olá, parabens pela notícia em 1ª mão!

Só q eu fiquei numa dúvida danada sobre o EasyPHP 1.7 q eu estou usando...

Agora q eu instalei o EasyPHP 1.7 estou com o seguinte dilema:
Os módulos instalados são:
easyphp 1.7 :
apache 1.3.27 -
php 4.3.3 -
mysql 4.0.15 -
phpmyadmin 2.5.3

Só q eu já pesquisei e baixei os seguintes módulos
Apache 2.0.50
PHP 5
MySQL 4.0.20d-win

Como eu faço para atualizar meu EasyPHP com esses novos módulos?!

Além do q quero instalar um servidor SMTP para testar as paginas em "localhost" (já baixei alguns q me recomendaram .... mas não sei o melhor para usar junto com o EasyPHP). Também descobri alguns administradores PHP, pensei em usar em paralelo como o phpmyadmin 2.5.3 q veio no EasyPHP para comparar o desempenho... será q é possível?

Enfim... o q devo fazer, Já estou nessa pesquisa na net até essa hora e não consegui ainda uma informação segura...
Vc poderia me ajudar!??!

Valeu !
Agradeço a tua atenção,
Miq
15/07/2004 2:28am (~12 anos atrás)

Viva o PHP5!!!

Seja bendita a orientação a objetos!!!


Vou baixar AGORA!!!! :)


14/07/2004 11:36pm (~12 anos atrás)

Novo Comentário:

(Você pode usar tags como <b>, <i> ou <code>. URLs serão convertidas para links automaticamente.)