0

PHP4, IIS4, NT4 e Interbase 5X e 6X - Ambiente inicial de desenvolvimento

criado por Alexandre R. S. Correia em 26/05/2004 11:03am
Antes de relacionar as etapas do ambiente, convém fazer alguns comentários e estabelecer o escopo deste artigo, são eles:

1- O presente artigo tem o objetivo principal de permitir ao usuário estabelecer um roteiro para configuração do ambiente inicial de trabalho (algo que deveria ficar pronto a um clique do mouse, todavia, ainda não é assim) ou seja, permitir que o usuário consiga desenvolver os primeiros SITES PILOTO, dentro de uma LAN (rede local – com servidores Win NT e clientes Win 9X) para num momento posterior, estando mais amadurecido, possa desenvolver “verdadeiras” aplicações p/ Web.

2- Não se trata de um tutorial, ou seja, um passo-à-passo detalhado para usuários que nunca ligaram um computador. DETALHES DO ROTEIRO AQUI DESENVOLVIDO DEVE-SE RECORRER À PRÁTICA MILENAR DE CONSULTA AOS MANUAIS, de preferência os em inglês, que são recheados de comentários tipo “pulo do gato”...

3- O presente artigo, não aborda aspectos de segurança, ou seja, determinados parâmetros serão alterados no PHP.ini sem considerar a segurança. Aspectos de segurança devem ser estudados detalhadamente tão logo, se consiga estabelecer o ambiente inicial. Em outras palavras, NÃO VÁ PUBLICAR NA WEB OS SITES AQUI DESENVOLVIDOS, antes estude e entenda os ASPECTOS DE SEGURANÇA;

4- Não venho aqui, defender se este, ou aquele é o melhor ambiente para desenvolvimento. O ambiente que abordo neste artigo é apenas a realidade da empresa que eu trabalho, e creio, seja a realidade de muitas outras, daí a minha disposição em compartilhar a experiência;

5- No mais espero que sejam úteis as minhas palavras e que críticas destrutivas, construtivas e tudo o mais que vier serão recebidas de braços abertos... Bom trabalho.

Comentários:

Mostrando 1 - 2 de 2 comentários
Não tenho esse arquivo "php4isapi.dll" no diretório do php e sim "php4ts.dll"

PHP instalado "php-4.3.6-installer.exe"
03/06/2004 12:06am (~12 anos atrás)

Grande unadec,

Putz... Quase que eu consigo...

Minha máquina: Windows Server 2003 com IIS .Net

O IIS funciona perfeitamente bem, pois tenho vários sites em ASP funcionando corretamente, inclusive com banco de dados MySql.

Tenho um site em PHP com MySql e não consigo fazer funcionar em minha máquina... Apesar de funcionar no provedor. Putz... Mas trabalhar assim é um saco...

Já fiz todas as configurações possíveis e completei com algumas suas faladas aqui neste artigo.

A única coisa que não tinha feito ainda era o filtro ISAPI... Mas depois que fiz conforme sua orientação o site nem abriu. Fui ver o IIS... Tava o filtro como "não carregado" ... Tem idéia do que eu preciso fazer mais??
Se eu retiro o filtro ISAPI o site volta a funcionar...

O mais interessante... AS páginas em html funcionam numa boa... Mas as páginas em PHP quando chamadas dão erro 404... Putz... coisa de loco... já que o arquivo está lá.

Se você ou mais alguém souber de algo...
03/06/2004 12:01am (~12 anos atrás)

Novo Comentário:

(Você pode usar tags como <b>, <i> ou <code>. URLs serão convertidas para links automaticamente.)